Cannot open project in ofSketch


#1

right now I just can’t open any projects in my ofSketch including the examples. Here is the console info, anyone knows how to deal with it?


#2

Did you install xCode? Also, what version of osx are you using?


#3

yes, I have xCode and my osx version is 10.10.5


#4

Hm. What version of Xcode do you have installed? Also, what is the output if you go to the command line and run:

xcode-select -p


#5

It shows my version is Version 7.0 (7A220)


#6

when I run the code, it shows ‘command not found’


#7

@bakercp Im having troubles with OfSketch as well.
getting only this even on new files

Makefile:13: /Users/temp/Documents/fall15/code/ofSketch: No such file or directory
Makefile:13: 0.4.0/data/openFrameworks//libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk: No such file or directory
make: *** No rule to make target `0.4.0/data/openFrameworks//libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk’. Stop.


#8

I tried to use xcode to open a openFrame work example , it also did not work. I am not sure if they have any relations.


#9

Ah, 7.0 was just released and hasn’t been tested with ofSketch yet. @AdrianChe if you open the terminal and type gcc does it offer you the option to install xcode command line tools?


#10

@kendallschauder Did you delete your old ofSketch and install a new one? Also what version of OSX and what version of Xcode do you have installed?


#11

@bakercp i fixed it i had changed the name of the folder, i changed it back and its working again.


#12

no it showed clang error: no input files


#13

Strange – so it sounds like the commands that ofSketch uses are available, but there seems to be something missing. I thin kit is directly related to Xcode 7 (openFrameworks and ofSketch has not been tested with it yet and Apple always changes some things). So could you try the following commands in the terminal and paste screenshots of the results:

ls -la /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/
xcode-select -v
xcode-select -p

Thx.


#14


#15

Please place a space after xcode-select before -v or -p . The -p and -v are arguments, not part of the program name.

(or just cut and paste from my examples above).


#16


#17

Aha. OK. So the xcode-select command is working and you have the right files, but it appears that Xcode version 7 does not include a 10.9 or 10.10 sdk.

Currently ofSketch only works if there is a MacOSX10.10.sdk or MacOSX10.9.sdk in that folder.

So, I need you to do a little hack to get ofSketch working …

Inside your ofSketch folder you’ll see a file here

Open that file with a plain text editor, erase everything and paste in the contents linked here:

https://gist.githubusercontent.com/bakercp/bec2deb534187533eec8/raw/2c29c569bd7ec28268d83b4d5f227811520e92b3/config.osx.default.mk

Then try to compile a sketch again.


#18


#19

Oops. My bad. Try the contents of this file. I messed up the syntax.

https://gist.githubusercontent.com/bakercp/bec2deb534187533eec8/raw/8ed5460605c48c8130374fd6b4bc92c455af0504/config.osx.default.mk


#20